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WinToolKit Network Inventory  
Getting Started  

Introduction  

Any company and organization needs to have hardware and software inventory information in order to plan upgrades or 
hardware/software purchases. This information gives you an overview on the quantity and other detail of exact hardware and 
software assets in the organization and helps to identify what assets need to be added or replaced.  

 Today every PC has tens of applications installed and consists of dozen components, including CPU, memory, motherboard, hard 
drive, etc. Manual collecting inventory information from one PC can take up to ten minutes. How long does it take to obtain an 
accurate inventory of tens, hundreds and thousands of PCs in your network? Also consider the fact that useful inventory information 
should be up to-date. It's not enough to collect asset information at the purchasing time, because configurations can be changed 
afterwards - administrators can replace or remove some hardware, users can install new applications, etc.  

 Is there an effective way to perform the software and hardware audit? WinToolKit Network Inventory allows automatic collecting of 
hardware and software asset information from remote PCs and provides various advantages:   

· �Fast automatic collection of asset information that significantly reduces your time and efforts  
· �Always up-to-date inventory information helps to make decisions easier  

Application Interface Overview  

The main application screen is divided in two parts. On the left side you can find the Machine Management area that displays the 

network tree and asset groups. Management toolbar  is used to execute main actions, for example, scan network or update 
inventory information. The full set of actions is available from the context menu on the tree. 

 

Other nodes in the Machine Tree represent particular asset categories for all computers in the network. Thus, if you need to check 
memory banks information only, you can expand Memory Banks root node in the tree and select domain/workgroup or particular PC 
in order to get information for them.  

In order to manage application settings you can switch tabs located under the Machine Tree.  The Settings tab allows you to 
manage information extracted from remote PCs, so you can enable or skip some parameters. The Alt Credentials tab is used to set 
administrative credentials applied to access remote PCs. If your account doesn't have administrative permissions on remote PCs 
you need to set administrative account on this tab.  

Information displayed on the right side of the main screen depends on the node, selected in the Machine Tree. For example, if PC 

node is selected, at the right side you can see Machine Summary information. Management toolbar  is located at the top of the 
summary and provides a quick access to the most frequent actions, such as report generation, locking and update functions. Under 

the toolbar  you can find Hardware, Software and System boxes with the correspondent information about any PC. 

The Machine Tree is located under the 
management toolbar and contains asset 
information that can be represented in  two 

ways. The Networking node  displays 
PCs found in the network, grouped by 
domains and workgroups. 

When some node under the Networking is 
selected, on the right side you can see 
related inventory information. For example, 
if you select particular PC, you can see its 
hardware and software asset summary. If 
you want to learn more about concrete 
asset, for example memory on particular 
PC, you can select Memory Banks under 
PC's node in the tree and get detailed 
information.  
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Collect Hardware and Software Information from Remo te PCs 

As you may know, WinToolKit Network Inventory allows you to make hardware and software inventory of remote PCs without 
installation of any agents on client computers. It simplifies the process, because in order to prepare to the remote inventory you 
need to check only two things. Firstly, you need to have administrative access to remote PCs. If your current account doesn't have 
administrative permissions, you need to go to the Alt Credentials tab and setup credentials. Secondly, you need to switch to the 
Settings tab and check what data will be collected from remote PCs. Please note that some data is collected through the Windows 
Management Instrumentation (WMI), so this service should be enabled on remote PCs.  

 
Pic 1 – Enumerate LAN options 

 
Pic 2 – Inventory scan results 

 

Collection of the inventory information is activated by the Enumerate LAN button located on the management toolbar. This button 
launches the network enumeration to detect PCs in all available domains and workgroups within the local network. Inventory 
information is extracted from all remote PCs and stored in the local database. If you would like to reduce the range of scanned PCs, 
you can choose other options, like a scan by IP range, available from the Enumerate LAN pop-up menu.  (Pic 1) 

After a scan the Machine Tree displays detected PCs grouped by domains and workgroups. You can browse the tree to see the 
inventory information for the selected tree node. Thus, you can see asset information for workgroup/domain or PC or components of 
particular PC, etc.  (Pic 2) 

When you make the first scan, the Machine Tree is filled by the collected data. Next time, when you need to make an inventory, you 
can choose to collect information from the new PCs available in the network, or to update information on existing PCs in the tree. In 
this case you need to use Fetch New or Update buttons on the management toolbar. If you make Enumerate LAN, then the network 
scan and the data collection procedure will be repeated again and your current data will be replaced by the new data. 

Browse, Filter and Analyze Inventory Information  

When collection of the inventory information is complete, you can browse it by selecting required nodes in the Machines Tree. By 
this way you can get the inventory information for each particular PC or the general overview for particular asset across the network. 
If you however have hundreds or thousands of PCs in the network, it's hard to find required information.  

 

Pic 4 – Custom Auto filter dialog 

�

WinToolKit Network Inventory can help you to easily 
manage and narrow information by applying filters. For 
example, let's detect problematic PCs, which have a lack of 
memory. In order to find them, select the domain or 
workgroup under the Networking node in the tree. 
Summary information about PCs in this domain or 
workgroup is displayed on the right side. This information 
includes Physical Memory field, so we can apply filter by 
this field to display only problematic PCs. Click on the down 
button on the field's caption and in appeared menu select 
(Custom...) item. On the Custom AutoFilter dialog select is 
less than option and enter 1024 value to display only those 
PCs, which have less than 1GB of memory. (Pic 4) Press 
OK button to apply the filter.  
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Prepare Inventory Report  

 

Pic 6 – Report customization options 

 

Pic 7 – Field Output Selection dialog 

����� � ����� �

Collecting information from remote computers is only a part of 
the inventory task. Usually, the asset information should be 
composed into printable reports for the management or further 
reference by IT team. WinToolKit Network Inventory provides 
few easy ways to prepare reports. Firstly, you can save 
information displayed on screen in various formats if you click 
on the Export Displayed button. Secondly, you can generate a 
set of detailed predefined reports. Thirdly, you can generate 
your own custom reports.  

All reports are customizable. It means that you can change the 
title page and add your name and company logo to it. To 
customize report select File > Preferences... item from the main 
menu and go to the Report tab. Change report Title, 
Description and set Author and Company Logo.  (Pic 6)Press 
OK button to apply settings.  

Let's create inventory report in PDF format for all PC. To 
generate the report select Reports > Machine Data > Export to 
File > All item from the main menu. On the appeared Field 
Output Selection dialog you can choose what data should be 
included into the report.  (Pic 7)Make you selection, press OK 
and proceed to the Save As dialog where you need to enter the 
file name and choose Adobe Acrobat Document as output 
format. Press the Save button to generate the report and open 
it in the Acrobat Reader. You can see the logo and customized 
captions on the title page. (Pic 8) Other pages contain 
information selected for inclusion into the report. (Pic 9) 
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Reconcile Software Licenses  

 

Pic 10 – Installed Applications Count dialog 

 

Pic 11 – Installed Application Exclude List dialog 

 

A list of installed applications for each PC is available under the 
Installed Apps node in the Machines Tree. It represents the 
same data as displayed by the Add/Remove Programs in the 
Control Panel. But if you have a lot of computers in the 
network, it's very hard to get the general overview of what 
software is used in the organization, because the information is 
represented per PC.  

The summary information about software used within 
organization is available in the Enterprise Edition on the 
Machine Tree under the Management Tools > Installed 
Applications. The Count Application node opens the dialog that 
represents all software items found in the network together with 
the number of used copies. (Pic 10) It helps you to have the 
summarized information about all software assets. But such 
representation has two disadvantages. Firstly, it includes all 
freeware that should often be skipped from the software assets 
evaluation. Secondly, it groups software by the full name 
coincidence, so same applications with different version 
numbers can be represented several times in the list.  

To filter out applications from the summary view, the Installed 
Application Exclude List dialog can be used. It is activated by 
the Maintain Exclude List node. In this dialog you can define an 
application name mask to remove all occurrences according 
with mask from the applications list.  (Pic 11) A similar 
functionality is available for application entries grouping. Using 
the Maintain Groups List node you can activate dialog where  
you set the mask and group name. All entries compliant to 
mask will be replaced by the defined group name.  (Pic 12) 

�

Finally, when freeware is filtered out and all groups are defined, you can select the Reconcile Licenses node to open 
correspondent dialog.  (Pic 13)This dialog can help you to review all software assets. You can see a number of used copies for 
each application and can enter the number of licenses that your organization owns to get the number of unused or required 
licenses. Such an approach can easily show licensing problems and simplify decision making for software purchases. 
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Detect  Licensing or Policies Violations on Remote PCs  

 

Pic 14 – Add Scan Task dialog 
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Pic 16 – Add Machines to Queue dialog 

�
Pic 17 – View Scan Results dialog 

�

WinToolKit Network Inventory has an ability to make a custom 
search on remote computers. You can define specific 
conditions to search resources on the file system and registry. 
This feature is useful in various cases, for example, to detect 
remote PCs with specific resources, settings or viruses, etc. It 
can also help to detect licensing or company policies violations. 
For example, let's detect PCs that have MP3 files on hard 
drives.  

�

Pic 15 – Add Scan Criteria dialog 

Remote search options are available in the Enterprise Edition 
under the Scan Operations node in the Machine Tree. To 
perform a files scan, select File System Scan node and press 
Add button to configure a new scan task. On the appeared 
Add Scan Task dialog enter scan task name and description.  
(Pic 14) New scan task will appear in the tree and you can 
select it to configure conditions. Click on the Add button on 
the toolbar and on the Add Scan Criteria dialog enter file 
mask *.mp3 and select %All Drives% as a search criteria to 
look for MP3 files on all available drives. Press OK button to 
finish.  (Pic 15) 

Next, we need to configure the search scope, so click on the Include Machine button located on the Machine Queue toolbar. On the 
appeared Add Machines to Queue dialog you can choose domains/workgroups or individual PCs where a search should be 
performed and press OK button to fill the Machine Queue.  (Pic 16) When search conditions and Machine Queue are configured, 
you can launch the search by pressing Run Now button on the toolbar. After scan completion you can see search results below. To 
get a detailed report about resources found, you can click on the row in the search results.  (Pic 17) 
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